
 

Copyright © 2018 PSI Services LLC, All Rights Reserved. 

Page 1 of 27 

RPNow Faculty & Student LTI 
Installation Guide 

 
 

PSI’s (listed as former name Software Secure) LTI integration allows teacher and/or admins to register 
exams in the RPNow system without having to leave the platform. Additionally, reports can be viewed 
from within the application. 
 
Installation keys for all course management systems must be provided to administrators by PSI- if you 

do not have these keys, please contact us at your organization’s distribution list 

<orgcode>@softwaresecure.com 

It should be noted, student email addresses for the school (i.e. @orgname.edu) need to be provided to 

the PSI Client Services team in order for the Student LTI system to properly integrate. 

In order to install the Student LTI, our Faculty LTI application must also be installed.  If you aren’t sure 
whether the Faculty LTI application is installed for your organization, please contact us.The keys for both 
installs are the same.  

 

 

 
 

  

http://www.softwaresecure.com/privacy-statement/
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Blackboard Faculty LTI Configuration 

Install Building Block 
Note: Please make sure all URLs have no “endspaces” after the URL itself as this can lead to errors. 

Before installing the tool, the RPNow Building Block must be installed by an Administrator or an 

Instructor who also has Configuration and Placement privileges in Blackboard Learn.   

1. Download the Building Block (B2) (do not unzip/extract the file): 

(B2 Version 2.1.2): https://www.sendspace.com/pro/dl/dx3x3u 

Note:  this Building Block should be compatible with Blackboard versions 2009 and greater 

2. To install the B2, navigate to System Admin> Building Blocks> Building Blocks> Installed Tools> 

Upload Building Blocks 

3. Select “Browse” and browse for the downloaded .war file from Step 1 

4. Click Submit 

Make available and setup “Connection” parameters 
1. After installing the B2, go to Building Blocks> Installed Tools> locate “Software Secure” from the 

list.  Select the arrow drop-down menu and make it “Available” 

 

 
 

2. From the arrow drop-down menu select Software Secure> Settings> Configure> Connection.   

3. Type the following keys into the areas provided. 

Your organization’s custom keys are below: 

a. Consumer Key = PROVIDED BY PSI-if you don’t have this please contact your 
organization’s support distro 

b. Token = PROVIDED BY PSI-if you don’t have this please contact your organization’s 
support distro 

c. Building Block Validation Endpoint = Auto-populated 

http://www.softwaresecure.com/privacy-statement/
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d. Software Secure Status Endpoint = Auto-populated 

4. You will need to provide the endpoint URL back to us.  

*Note: The integration will *not* work until we get the endpoint back from you 

5. Select “Submit” 

 

Confirm Role Mapping 
1. Navigate to Building Blocks> Installed Tools> Software Secure> Settings> Configure> Role 

Mapping. The roles are based upon your organizations preferences. In general, both Instructors 

and anyone else within the course that may assist the instructor should be given “Instructor” 

access. 

*Note:  Anyone with Instructor role access in the course will be permitted to view 

videos/IDs/reports for students within the course 

2. Students/Learners should have “Learner” status. Students are not able to use this application 

directly.  They will receive “unauthorized user” errors if they attempt to access the LTI 

application 

3. Click “Submit” when completed 
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Operational Settings 
1. Navigate to Software Secure> Settings> Configure> Operational Settings 

2. By default, “Communication with Software Secure” is enabled.  This is required 

3. Optional: Enable “Log communications to the Blackboard server” 

4. Select “Submit” when completed 

 

 

Add Faculty LTI Provider Domain 
1. Navigate to Building Blocks> Building Blocks> Basic LTI Tool Providers 

2. Select “Register Provider Domain” and configure with the following settings.  Non-listed items 

are not required. 

a. Provider Domain Status: 

i. Provider Domain: lti.rpexams.com 

ii. Provider Domain Status: Approved (default) 

iii. Secondary hostnames: Not required 

 
 

b. Default Configuration: 

i. Set Globally 

ii. Tool Provider Key: Insert “Provider Key” from “Make Available and setup 

‘Connection’ Parameters; Step 2” 

iii. Tool Provider Secret: Insert “Provider Secret” from “Make Available and setup 

‘Connection’ Parameters; Step 2” 

http://www.softwaresecure.com/privacy-statement/
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iv. Tool Provider Custom Parameters: Ensure the following is listed (Copy and 

Paste): 

course_role=@X@course.role@X@ 
tool_consumer_info_product_family_code=blackboardlearn 
system_role=@X@user.role@X@ 
 

 
 

c. Organization Policies 

i. Send User Data: Only over SSL 

ii. User Fields to Send (require all items): 

1. Constituency (Role) in course 

2. Name 

3. Email address 

iii. Send Context Identifiers as: Primary Key 

 

 
 

3. Click Submit 
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Create Faculty LTI Placement 
Once configuration (for Connection, Role Mapping, and Operational settings, respectively) is completed, 

and the Domain has been added, “Placements” must be created. This is what allows faculty to place the 

LTI application within their course and determines where, within their course, it can be placed. 

 

1. Navigate to Building Blocks> Building Blocks> Basic LTI Tool Providers> Locate lti.rpexams.com 

and choose “Manage Placements” 

2. Select “Create Placement” and use the following parameters: 

a. Placement Information 

i. Label: RPNow Faculty Exam Registration (can be customized) 

ii. Handle: RPNowfacultylti (can be customized) 

iii. Type: 

1. Student Tool or 

2. Content Type: Tools 

*Note: Both “Types” above are available. However, we recommend creating it 

as a “Student Tool” or using both options.  Although students do not use this LTI 

application, setting it up as a “Student Tool” allows a placement to be used that 

is more convenient and easily located for faculty. 

 

In contrast, the “Content Type: Tool” placement will require faculty to create a 

placement in potentially numerous areas within their course, depending upon 

their folder structure/class setup. 

 

 
 

b. Tool Provider Information 
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i. Tool Provider URL: https://lti.rpexams.com/init  

ii. Tool Provider Key: Should be auto-included; cannot edit 

iii. Tool Provider Secret: Should be auto-included; cannot edit 

 

  

3. Click Submit 

Provide Permission to use the LTI App 
 

The admin permissions (i.e. “System Config”) area allows admins to determine if courses have 

permission to use the LTI Tool. Although a faculty member may be able to see the LTI tool in his/her 

course, the admin can prevent the faculty from proctoring with RPNow by not providing permissions. 

As a default, organizations will be set up by RPNow to have proctoring either enabled or disabled for all 

courses.  Bulk assigning permissions allows the admin to select specific courses that would differ from 

the default setting. 

1. To load the LTI Application navigate to any course that has the LTI App available. 

*Note: admins can always load the LTI tool within any course, the permissions simply allow or 

prohibit faculty from using it. 

2. Within the LTI Application, navigate to System Config> Proctoring Permissions> Bulk Assign 

Permissions 

3. Search the course(s) you would like to either enable or disable with RPNow LTI proctoring access, 

and select the “Registration Method” you would like to allow. We suggest you use the “Dual Mode” 

as this will allow faculty to use native Blackboard exams and/or third-party exams (MyMathLabs, 

etc).  

Various settings available: 

1. Enable/Disable course permissions from using RPNow to proctor exams 

http://www.softwaresecure.com/privacy-statement/
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2. Force a faculty to only use the native (Blackboard) system for exams (i.e. “LMS” 

exams), or  

3. Allow faculty to use third-party exams (Such as MyMathLab; i.e. “Third 

Party/Manual Mode”) or 

4. Allow both options, so faculty can use a combination of Blackboard and/or 

MyMathLab exams, for example. 

For more details:  

Go to: http://library.blackboard.com/ref/df5b20ed-ce8d-4428-a595-

a0091b23dda3/Content/_admin_app_system/admin_app_basic_lti_tool_providers.htm 

Blackboard Student LTI Configuration 

Register Student LTI Provider Domain 

1. Log into Blackboard 
2. Go into System Admin> Building Blocks> Basic LTI Tool Providers 
3. Click “Register Provider Domain” 
4. Fill in the form:  

o Provider Domain Status 
▪ Provider Domain: student.rpexams.com  

o Default Configuration 
▪ Default Configuration: Set globally for each link 
▪ Use the same keys as used for “Faculty LTI”. 

o Organization Policies 
▪ Send User Data: Send user data only over SSL 
▪ User Fields to Send: “Constituency in Course”, “Name” and “Email 

Address” must be selected 
o Show User Acknowledgment Message: No 

5. Submit 

Create Student LTI Placement  

6. Click arrow marker next to “student.rpexams.com”, select “Manage Placements” 
7. Click “Create Placement” 
8. Fill in the form:  

o Placement Information 
▪ Label: RPNow for Students (can be customized) 
▪ Handle: rpnowforstudents (can be customized) 
▪ Type: Student Tool 

o Tool Provider Information 
▪ Tool provider URL: https://student.rpexams.com/init  
▪ Tool Provider Key: Use the same access key used as for Faculty LTI 
▪ Tool Provider Secret: Use the same secret key used as for Faculty LTI 
▪ Tool Provider Custom Parameters: username=@X@user.id@X@  

http://www.softwaresecure.com/privacy-statement/
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- This custom parameter is required to send the Student's User ID 
into LTI Student 

9. Submit. At this point, the placement will be ready. You will need to add the new link to 
all courses in which you want Students to be able to launch the LTI Student application. 

Add Blackboard RPNow Faculty or Student LTI apps into a course 
 

Once the above steps are completed by the System Administrator, the actual LTI Application link must 

be placed within the course. Note that access to the tool and permissions to use the tool are two 

different options. A course might have the tool option available but may not be setup to use the tool 

(and it would then give an error to the faculty). For LTI to be used, both permissions to use the app AND 

the access to the tool must be provided. There are two methods available: 

1.  System Administrator Implementation Option (System wide customization): 

Create an institutional hierarchy (Node) within Blackboard. This will allow the system 

administrator to enable/disable the LTI Application within specific courses (arranged via 

the Node). Navigate to System Admin> Communities> Institutional Hierarchy> Create 

Nodes.  

*Note:  Nodes are completely organization-based (the setup can be determined based 

upon campuses, departments, colleges, and so on within the university/organization). 

As such, we suggest you refer to this URL or your Blackboard administrator/contact for 

assistance with setup: https://en-

us.help.blackboard.com/Learn/Administrator/Hosting/Tools_Management/Institutional

_Hierarchy_for_Community_Engagement/020_Managing_Courses_Orgs_Users_in_Nod

e 

 

 
 

2. Instructor Implementation Option (Course specific) 

*Note: Admins, like instructors, can complete these steps, though the Nodes information above 

provides a faster, more robust method. 

Instructors can create the LTI Application link themselves by going into their course (in 

which the System Administrator has allowed/enabled the LTI application to be used). 

The method at which they can create the link depends upon how the System 

Administrator created the “Placement” (Student or Course Tool Method - See “Create 

Placement” sections above.): 

a. Student Tool Method:  

http://www.softwaresecure.com/privacy-statement/
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i. Instructors will load their course 

ii. Navigate to the “Add Course Menu” button 

iii. Select “Tool Link” 

iv. Name: Faculty can call it whatever they prefer, but Register RPNow Exams is 

recommended for the Faculty LTI app.  The Student LTI app name 

recommendation is Take RPNow Exams.  

v. Type: Choose “RPNow Faculty Exam Registration” for the Faculty LTI or “RPNow 

for Students” from the available options (the name will be displayed as the 

name provided during the creation of the placement.) 

vi. DO NOT check make “available to users” box for the Faculty LTI app—students 

cannot use this application and will receive “Unauthorized Access” error 

messages 

vii. Click Submit 

viii. A new link will be made available within the course menu itself; allowing better 

access for faculty than the “Course Tool Method”. 

 

 
 

b. Course Tool Method: 

i. Faculty will open the course, then navigate to the content folder where they 

would like to place the link 

ii. Click Tools> More Tools (if required)> locate and select “RPNow Faculty Exam 

Registration” for the Faculty LTI or “RPNow for Students” from the available 

options (the name will be displayed as the name provided during the creation of 

the placement.) (the name will be displayed as the name provided during the 

creation of the placement.) 

iii. Name: Faculty can call it whatever they prefer, but “Register RPNow Exams” is 

recommended for the Faculty LTI app.  The Student LTI app name 

recommendation is “Take RPNow Exams”.   

iv. Description and Attachments are not required 

v. Options: Permit Users to View this Content: SELECT NO.  Students cannot use 

the Faculty LTI application and will receive “Unauthorized Access” error 

messages. 
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Canvas Faculty LTI Configuration 
Requirements 
Canvas hosted in the Instructure Cloud is fully supported.  Instructure Cloud is always at or near the 

latest version of Canvas. If you self-host Canvas, additional configuration may be required. 

Installation and Configuration 
1. Login as an admin and navigate to: Admin> Account Name > Settings> Apps.  

2. Select “View App Configurations”.  

 

 

3. Select the “+ App” button and fill out the page: 

a. Configuration Type: “By URL” 

b. Name: “RPNow Faculty Exam Registration” (Can be customized)  

c. Consumer Key: PROVIDED BY PSI-if you don’t have this please contact your 

organization’s support distro  

d. Shared Secret: PROVIDED BY PSI-if you don’t have this please contact your 

organization’s support distro 

e. Config URL: There are two URLs for Faculty LTI Installation to pick from: 

i. https://lti.rpexams.com/lti/install/instructor will install the application into 

*ALL* courses.  

http://www.softwaresecure.com/privacy-statement/
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ii. https://lti.rpexams.com/lti/install/instructor-nonav will install the application 

into *ZERO* courses—the link to the LTI App can then be added individually into 

each course. See below for instructions to add the app to individual courses.  

f. Select “Submit”. 

 
 

Canvas Student LTI Configuration 

Installation and Configuration  
 

Login as an admin and navigate to: Admin> Account Name > Settings> Apps. 

1. Select “View App Configurations”.  

2. Select the “+ App” button and fill out the page: 

a. Configuration Type: “By URL” 

b. Name: “RPNow for Students” (Can be customized)  

c. Consumer Key: Use the key provided for your Faculty setup. 

d. Shared Secret: Use the key provided for your Faculty setup. 

e. Config URL: There are two URLS for Student LTI Installation to pick from: 

i. https://lti.rpexams.com/lti/install/student will install the application into *ALL* 

courses.  

ii. https://lti.rpexams.com/lti/install/student-nonav will install the application into 

*ZERO* courses—the link to the LTI App can then be added individually into 

each course.  

f. Select “Submit”. 

http://www.softwaresecure.com/privacy-statement/
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Adding the Canvas Faculty or Student LTI Link into specific courses  
It should be noted, this option is only available if the “nonav” By URL was used during the 

Faculty/Student LTI application install.  

1. Navigate into the course that will use the RPNow LTI app. 

2. Select Modules> “+ Module”> Provide the Module a name (suggested:  RPNow Links). You can 

use the same Module for your Faculty and Student LTI links; however, you MUST hide the 

faculty link from students and ensure only the “Student LTI” link is available. 

3. Select the “+” sign next to the new Module. 

4. In the drop-down screen, select to add “External Tool”.  

5. Locate the Faculty or Student LTI tool- this will be what you named the tool during installation.  

For Faculty LTI it should be “RPNow Faculty Exam Registration” and for Student LTI it should be 

“RPNow for Students” 

6. Select “Add Item” 

7. Once added, students/faculty can go to the Module to access the RPNow Faculty and Student 

LTI applications.  

Brightspace Faculty LTI Configuration  

Requirements 
All D2L Learning Suite versions 10.4 or higher are supported. If you are using versions 10.4 to 10.7 

please let your account representative know by contacting your organizations support distro. 

(<orgcode>@softwaresecure.com) Clients using D2L Learning Suite on the Brightspace cloud should 

already be at or above this version or will be able to update fairly easily. 

Generating Local Keys  
Note: Please make sure all URLs have no “endspaces” before or after the URL, itself as this can lead to 

errors. 

In order for the LTI App to work, a set of “local keys” must be generated and sent to us.  

1. Navigate to Admin Tools (Gear Icon)> Manage Extensibility (Under “Organization Related”)>  

Register an App 

a. Application Name: RPNow 

b. Trusted URL:  

i. If using Brightspace 10.7 or previous: https://lti.rpexams.com/d2l/auth   

ii. If using Brightspace 10.8 or higher: https://lti.rpexams.com/d2l/auth  

c. Check to “Enable this application” 

d. Accept the terms 

http://www.softwaresecure.com/privacy-statement/
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e. Click “Register Application” 

 

2. After registering the application, keys will be created; send these keys to the PSI team. Send us 

both the “Application ID” and “Application Key”. You will need to click “Show” in order to see 

the “Application Key”.  

 

 

Installation and Configuration 
NOTE: Do not complete these steps until you have provided your local keys to PSI—see previous steps. 

1. Navigate to Admin Tools> External Learning Tools (under “Organization Related”)> New Link 

 

 

a. Title: RPNow Faculty Exam Registration 

b. URL: 

i. If using Brightspace 10.7 or previous: PLEASE ALERT YOUR PSI REPRESENTATIVE 

BUT INSERT https://lti.rpexams.com/init 

ii. If using Brightspace 10.8 or higher: https://lti.rpexams.com/init 

 

c. Under “Key/Secret”: 

i. Leave “Sign Messages with key/secret with” checked 

http://www.softwaresecure.com/privacy-statement/
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ii. Select “Link Key/secret” 

1. Key: PROVIDED BY PSI-if you don’t have this please contact your 

organization’s support distro 

2. Secret: PROVIDED BY PSI-if you don’t have this please contact your 

organization’s support distro 

 

d. Security Settings 

i. Ensure “Use link security settings” is selected 

ii. Check all boxes 

 
 

e. In order to limit which courses the LTI App is available in, select “Add Org Units” 

 

http://www.softwaresecure.com/privacy-statement/
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f. Select “Save and Close” 

Role Mapping:  
g. Navigate to Admin Tools> IMS Configuration (Under “Organization Related”)> and 

ensure the roles that should be able to use this LTI App (Normally Instructor and 

Administration) has “Instructor” and/or” Administration” checked.  

 

Documentation 

- Primary Documentation: 

https://documentation.desire2learn.com/en/Learning%20Tools%20Interoperability%20standar

ds%20support  

- Adding link to Tool Provider: https://documentation.desire2learn.com/en/setting-up-link-to-

tool-provider  

- Enabling LTI: https://documentation.desire2learn.com/en/org-level-lti-configuration 

- Registering Limited Apps/Generating API Keys: 

https://community.brightspace.com/devcop/blog/new_app_registration_process__easy_and_i

nstant 

Brightspace Student LTI Configuration 

Installation and Configuration 
Note: Please make sure all URLs have no “endspaces” before or after the URL itself as this can lead to 

errors. 

1. Login as an Administrator 

http://www.softwaresecure.com/privacy-statement/
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2. Navigate to Admin Tools> External Learning Tools (under “Organization Related”)> New Link 

a. Title: RPNow for Students  

b. URL: https://student.rpexams.com/init 

 

 
 

c. Under “Key/Secret”: 

i. Leave “Sign Messages with key/secret with” checked 

ii. Select “Link Key/secret” 

1. Key: (same as your “LTI Faculty Key”) 

2. Secret: (same as your “LTI Faculty Secret”) 

 

d. Security Settings 

i. Ensure “Use link security settings” is selected 

ii. Check all boxes 

http://www.softwaresecure.com/privacy-statement/
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e. In order to limit which courses the LTI App is available in, select “Add Org Units” 

 

 

Add Brightspace Faculty or Student LTI apps into a course 
If you’d like to add RPNow into the navigation bar for every course, you’ll click on the “Course Admin” 

button on the home screen.  This button is located within the main navigation bar at the top of the screen. 

If you’d like to add the RPNow app into a single course, you’ll click on the “Course Admin” button within 

that course.  

From here, you’ll choose “Navigation & Themes” under “Site Setup.”  The first tab allows you to 

edit/create “Navbars,” the second tab allows you to edit/create “Themes” and the third tab allows you to 

edit/create “Custom Links.” 

You’ll need to make sure you are on the first tab, where you can select the nav bar you added for RPNow 

for Faculty to.  

Click on the copy you’ve created and you’ll see a list of links.  Click “Add Links” and then choose “Create a 

Custom Link.”  Name the link “Register RPNow Exams” if adding the Faculty LTI app or “Take My RPNow 

Exams” if adding the Student LTI app and choose “Insert Quicklink.”  Scroll down and choose “External 

Learning Tools,” then choose the RPNow app you created upon installation.  You should choose to have 

this open in the “Same Window,” it should be noted that on the Faculty LTI under “Availability” you should 

“Limit this to specific roles” and only make this available to Faculty and administrators. This link will 
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automatically be selected from the list, click “Add” and “Save and Close” and the app will be available in 

the navigation bar.  

Moodle Faculty LTI Configuration  

Requirements 
All Moodle versions 2.2 and higher are supported. 

Installation and Configuration 
Note: Please make sure all URLs have no “endspaces” after the URL itself as this can lead to errors. 

1. Login as an Administrator 

2. Navigate to Site Administration> Plugins> Activity Modules> External Tool> Manage Tools 

3. Click to “Configure a Tool Manually” 

 

 

a. Tool Name:  RPNow Faculty Exam Registration 

b. Tool Base URL/Cartridge URL: https://lti.rpexams.com/init   

c. Consumer Key: PROVIDED BY PSI-if you don’t have this please contact your 

organization’s support distro 

d. Shared Secret: PROVIDED BY PSI-if you don’t have this please contact your 

organization’s support distro 

Skip to the “Privacy” section 

e. Share Launcher’s name with tool: Always 

f. Share launcher’s email with tool: Always 

g. Check the box for “Force SSL” 
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h. All other settings on the page are optional 

Note: You may have to check a box to require it to show up as an “external tool” in 

Moodle. This is based off the theme that is used, and may not be required. 

Note: For Moodle 3.0, check the box to “Show tool type when creating tool instances” 

must be checked. 

Documentation 

- Moodle External Tools: https://docs.moodle.org/32/en/External_tool_settings 

Moodle Student LTI Configuration 

Requirements 
All Moodle versions 2.2 and higher are supported. Student LTI requires that Faculty LTI be installed. 

Please refer to your “Faculty LTI Installation Instructions” documentation. 

Installation and Configuration 
Note: Please make sure all URLs have no “endspaces” after the URL itself as this can lead to errors. 

1. Login as an Administrator 

2. Navigate to Site Administration> Plugins> Activity Modules> External Tool> Manage Tools 

3. Click to “Configure a Tool Manually” 
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a. Tool Name: RPNow for Students 

b. Tool Base URL/Cartridge URL: https://student.rpexams.com/init  

 

 
 

c. Consumer Key: (same as your “LTI Faculty Key”) 

d. Shared Secret: (same as your “LTI Faculty Secret”) 

Skip to the “Privacy” section 

e. Share Launcher’s name with tool: Always 

f. Share launcher’s email with tool: Always 

g. Check the box for “Force SSL” 

 

 

h. All other settings on the page are optional 
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Note: You may have to check a box to require it to show up as an “external tool” in 

Moodle. This is based off the theme that is used, and may not be required. 

Note: For Moodle 3.0, check the box to “Show tool type when creating tool instances” 

must be checked. 

Add Moodle RPNow Faculty and Student LTI apps into a course  
Faculty/Admins can add RPNow  apps to a course by: 

1. Navigate to the course you wish to add the Faculty or Student LTI app  

2. Ensure edit mode is enabled 

 

 

3. Select “Add an activity or resource” 

Note: We suggest you add this to the main/header bar of the course 

 

 

4. Choose “External Tool” from the pop-up window 

 

 

5. Click “Add” 

a. Activity Name: Register RPNow Exams (for Faculty LTI) 

Take RPNow Exams (for Student LTI) 

b. Preconfigured Tool:  Choose the tool that was installed above – RPNow Faculty Exam 

Registration for Faculty LTI or RPNow for Students for Student LTI  
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c. Skip to “Common Module Settings” –  

i. Visible: Show 

 
 

d. Select “Save and return to course” 

Documentation 

- Moodle External Tools: https://docs.moodle.org/32/en/External_tool_settings 

Third Party Faculty LTI Configuration  

Requirements 
The CMS/LMS used must be LTI compliant. We encourage you to ensure the system is password 

protected; otherwise users may take the exam without being proctored. 

Installation and Configuration 
1. Login as the necessary user to install the keys (i.e. generally an admin account) 

2. Navigate to your LTI Application Installation area. 

3. Complete any required fields using the information below to assist. 

a. Tool Name: RPNow Faculty Exam Registration 

b. Tool Base URL/Cartridge URL: https://lti.rpexams.com/init  

c. Consumer Key: PROVIDED BY PSI-if you don’t have this please contact your 

organization’s support distro 

d. Secret Key: PROVIDED BY PSI-if you don’t have this please contact your organization’s 

support distro 

e. Skip to the “Privacy” section 

f. Share Launcher’s name with tool: Always 

g. Share launcher’s email with tool: Always 

h. “Force SSL” can be enabled, but is not required 

i. Configuration Type: Manual 

Documentation: 

Schoology: https://support.schoology.com/hc/en-us/articles/204377963-A-How-to-Guide-for-

Schoology-s-LTI-Integration (See page 5) 

 

http://www.softwaresecure.com/privacy-statement/
https://docs.moodle.org/32/en/External_tool_settings
https://lti.rpexams.com/init
https://support.schoology.com/hc/en-us/articles/204377963-A-How-to-Guide-for-Schoology-s-LTI-Integration
https://support.schoology.com/hc/en-us/articles/204377963-A-How-to-Guide-for-Schoology-s-LTI-Integration


 

Copyright © 2018 PSI Services LLC, All Rights Reserved. 

Page 26 of 27 

Third Party Student LTI Configuration 

Requirements 
The CMS/LMS used must be LTI compliant, and Faculty LTI must be installed prior to installing Student 

LTI. 

Installation and Configuration 
1. Login as the necessary user to install the keys (i.e. generally an admin account) 

2. Navigate to your LTI Application Installation area. 

3. Complete any required fields using the information below to assist. 

a. Tool Name: RPNow for Students (can be customized) 

b. Tool Base URL/Cartridge URL: https://student.rpexams.com/init  

c. Consumer Key: same as your LTI Instructor key 

d. Secret Key: same as your LTI Instructor key 

e. Skip to the “Privacy” section 

f. Share Launcher’s name with tool: Always 

g. Share launcher’s email with tool: Always 

h. “Force SSL” can be enabled, but is not required 

i. Configuration Type: Manual 

Add Third-Party Faculty or Student LTI apps into a course 
Faculty/Admins can add the Student LTI into a course by: 

1. Navigate to the course you wish to add Student LTI into: 

a. Depending on the system used, Faculty and/or admins can allow the app into the 

course. See “Documentation” for additional information for your system. 
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Change Log 

5/23/18 Combined install docs- made minor changes  

8/2/18 Removed Developer Keys section from the Canvas install document 

8/2/18 Changed incorrect instructions for adding RPNow into a course for BB 

8/2/18 Combined the instructions for adding RPNow into a course for Faculty/Student 
LTI into one section per CMS  

8/2/18 Changed the Canvas instructions to include the “By URL” for the XML files  

8/2/18 Changed Key sections so they say the keys will be provided by PSI  
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